certmaster.spec: Try to simplify the support for rhel3+python2.3 a little bit.
[certmaster.git] / certmaster.spec
index afd2b6b..ced8847 100644 (file)
@@ -1,8 +1,19 @@
 
+
+# We can run on Rhel 3'ish systems, but only if python2.3 is installed 
+%if 0%{?rhel} == 3
+%define __python_ver 2.3
+%endif
+%define python python%{?__python_ver}
+%define __python /usr/bin/%{python}
+
+
+%{!?python_version: %define python_version %(%{__python} -c "from distutils.sysconfig import get_python_version; print get_python_version()")}
 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 %define is_suse %(test -e /etc/SuSE-release && echo 1 || echo 0)
 
+
 Summary: Remote certificate distribution framework
 Name: certmaster
 Source1: version
@@ -11,21 +22,33 @@ Release: %(echo `awk '{ print $2 }' %{SOURCE1}`)%{?dist}
 Source0: %{name}-%{version}.tar.gz
 License: GPLv2+
 Group: Applications/System
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
+BuildArch: noarch
+Url: https://fedorahosted.org/certmaster
+
+%if 0%{?rhel} == 3
+Requires: %{python}
+Requires: pyOpenSSL-py23
+%else
 Requires: python >= 2.3
 Requires: pyOpenSSL
-BuildRequires: python-devel
+%endif
+
+# NOTE: if you 
+BuildRequires: %{python}-devel
 %if %is_suse
 BuildRequires: gettext-devel
 %else
 %if 0%{?fedora} >= 8
 BuildRequires: python-setuptools-devel
 %else
+%if 0%{?rhel} >= 5
 BuildRequires: python-setuptools
 %endif
 %endif
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
-BuildArch: noarch
-Url: https://fedorahosted.org/certmaster
+%endif
+
+
 
 %description
 
@@ -46,7 +69,7 @@ rm -fr $RPM_BUILD_ROOT
 
 %files
 %defattr(-, root, root, -)
-%if 0%{?fedora} > 8
+%if "%{python_version}"  >= "2.5"
 %{python_sitelib}/certmaster*.egg-info
 %endif
 %{_bindir}/certmaster
@@ -108,6 +131,19 @@ fi
 
 
 %changelog
+* Mon Jan 19 2009 Adrian Likins <alikins@redhat.com> - 0.24.4
+- make inclusion of egginfo dependant on having python >= 2.5
+- remove need for patch on rhel3+python2.4 cases (distutils should
+  do all the /usr/bin/python renaming now)
+- minor reformatting changes
+
+* Tue Jan 06 2009 Greg Swift <gregswift@gmail.com> - 0.24-3
+- Fixed spec because it was only building in rhel3
+
+* Wed Dec 31 2008 Greg Swift <gregswift@gmail.com> - 0.24-2
+- Patched SPEC to build on rhel3 with python2.3
+- Added Patch0 to handle python2.3 if on rhel3
+
 * Mon Dec 12 2008 Adrian Likins <alikins@redhat.com> - 0.24-1
 - add missing dirs as per bz#473633